e107help.org Q&A
0 like 0 dislike
My installation stops at step 6 in version 2.1.7
e107 version 2.1.7
asked in Installation by (7 points) 4
Provided info to narrow, need to know php version, update etc.. Is php 7.2 in use? (work in progress, something in that version gives problems) If possible use a lower version eg in the 7 - 7.1 branch. The more info the better can be helped

2 Answers

0 like 0 dislike
Best answer
I do believe the error you experienced is 'fixed' , some alterations are made to the systems files.
Best to update with Github pack >  https://github.com/e107inc/e107  right side; take a zip (delete the install file) and overwrite ..
answered by (2.8k points) 5 9 18
selected by

I did that and I'm still stuck on Page 6 of the install.  I assume that it's because Website Theme section is blank and I can't select anything.

  • Apache/2.4.29 (Win32)
  • OpenSSL/1.1.0g
  • PHP/7.2.2
Using the latest  Xampp ? Is install path so no updating/overwrite, use the full (dev)pack you can download from Github, not the one from org.
It is XAMPP 7.22.

Yes...I installed XAMPP to C:\XAMPP to avoid the windows read/write issues.

I did download the full pack from Github as your answer suggested.  I tried three times before posting here.  I then left for the vet.  When I returned a couple of hours later it finished the install without issue.  Is the install reliant on e107.org/themes being available?  Seems strange but it's the only thing I can think of that might have changed while I was at the vet.
Caching is likely to be the culprit here, either browser (local) or on the server.
0 like 0 dislike

 Is the install reliant on e107.org/themes being available?

No it is not, as all needed, is on the (zip) pack.

Note: when running admin it will try to contact the e107 server for latest update availability and messages on plugins/themes/news

To be sure i downloaded the latest Xampp and installed...I do have to asume you are aware of the folowing points (these become more important since the serverpacks are being rewritten to comply with newer php versions..) >

Visual Studio C++ 2017 aka VC15

Be sure !! that you have installed the latest C++ Redistributable Visual Studio 2017 : vc_redist_x64 or vc_redist_x86 (updated 5 December2017).

 (php info page third line : Compiler MSVC15 (Visual C++ 2017) !!! (is it there?) Although compat with VC14 should exist...carefull... (so it is for xampp and also wamp).: here's my info:
 

e107 
Version 2.1.8 (git) 

Security level 
[5] Balanced 

Site Theme 
bootstrap3

Admin Theme 
Bootstrap 3 v1.0 by e107 Inc (2013-12-25)

Install date 
Sunday 18 February 2018 - 13:22:48  (actual time is for me +1 hour) server time

Server 
Apache/2.4.29 (Win32) OpenSSL/1.1.0g 
(host: localhost) 

PHP Version 
7.2.2 

MySQL 
10.1.30-MariaDB
Database: XXXXXXXX
PDO: Enabled 
Mode: NO_ENGINE_SUBSTITUTION 

Charset 
utf-8 

Server Time 
Sun, 18 Feb 2018 13:24:09 +0000
As you can see it is created just before this posting, and i have NO issues whatever.. It installs (about 3-4 minutes). Posting here  time  +/- 14:35  (13:35 +1)
No settings changed, using all fresh without any extra things.. Install xampp, create folder in htdocs (e107 is unpacked), run install > done...
One confession to take into consideration : i do not know if the new Xampp has VC15 build in, as i already had it installed on my pc 

 

answered by (2.8k points) 5 9 18
Welcome to e107 Q&A, where you can ask questions and receive answers from other members of the e107 community.
759 questions
1,169 answers
1,992 comments
1,387 users