e107help.org Q&A
0 like 0 dislike
Updated from v1.x (I think it was v1.0) to 2.1.15 and now using theme bootstrap 3 and with php version 5.6.30

The forum I use is the forum plug in, v 1.2. There is an option to upgrade to 1.2, but it is the same I use now?!

The forum shows all my subforums and also number of topics, replies and time stamps on the main page of the forum. But when I try to read the subforum all I get is "There are no topics in this forum yet.", but clearly there are. So, what am I missing here? I have the possibility to upgrade to php 7.1, but I have not done that yet, should I do that? And will that have anything to do with forum posts that are not shown?

In "my admin" in my php-handler I can see that a new post is created "_forum_post" and it contains my newly inputed test topic, but all the other old forum posts are placed in "_forum_t", could this have something to do with this issue?

If I post a new forum post, the forum posts the new topic, but when I try to read it, it only showns me the heading and not the forum post text. The reply also ends up in the category "forum_post" in my php admin

//Math
e107 version 2.1.15
asked in Plugins by (22 points) 1 2 5
edited by
Best update setting achieved if v1 was version 1.0.4 and than update..Do you have PRE update backup of dbase? Could be worth the effort.. If you are getting that forum can have/may be updated (despite v num) do it (can possibly related to some extra settings..). Please do NOT update to php 7.x if this update not runs nicely..It may cause more troubles (if there are). What kind of older v1 plugins are running?. Yes lot of remarks and questions but there is a need for more info.
Answer below as a new post.

4 Answers

0 like 0 dislike
Best answer

So, solved.

I deleted the two existing php-posts: "forum_thread" and "forum_posts" in the php-database.

Those two halted the upgrade process. Once deleted everything went smooth and by the book.

The forum is now fully operational and all good. Thank you for the assistance!

Lessons learned 1: Upgrade in correct sequence and do not do a short cut. (my mistake was that I made a test post in the forum before all upgrades were completed, so my fault.)

Lessons learned 2: My personal capability in handling php-databases have increased a lot :)

 

Thank you for all help.

 

//Math

 

 

answered by (22 points) 1 2 5
selected by
0 like 0 dislike

I have kept a backup of my old e107 installation. Its version 1.0. All the files I have stored as a copy on my local computer. I also saved a backup of my php-database at the same time. Is it only to copy those two copies back to my webserver and php-database to do a rollback?

Running (installed) plugins (version number):

AddThis (1.1)

Auto gallery (2.53)

Ban helper (1.5) (Not in use)

Banners (1.0) (Not in use)

Event calendar (3.6)

Downloads (1.0)

e107 newsletter (2.76)

e-tweet (0.9.3) (not in use)

Feature Box (1.1)

Forum (1.2)

 

I did not uninstall plug ins that are not in use, because when uninstalling it states that it will uninstall and clear my tables and I didnt want to mess them up, right or wrong?!

There is also the issue with different tables in my php. Old forum posts are in "_forum_post" but all new ones are stored in "_forum_t", but still all the old posts are counted for in number of topics and replies.

I have tried to "update" the forum to v1.2. The process is halted in "step 2" -->

Creating table forum_thread

Creating table forum_post

Creation of table(s) failed. You can not continue until these are created successfully!


//Math

answered by (22 points) 1 2 5
edited by

q: Is it only to copy those two copies back to my webserver and php-database to do a rollback?   normally yes; an empty site would only need files + dbase filled (make sure your config file does carry the good paths

BUT !!! (helas)
 let's hope the php version does not influence your roll back. it is not the nicest version, and that could make significant differences. Most likely that is why the update did not work as intended. (glad that you have copies !! make sure you do not delete them). (in an what to do now situation)..

Some of those plugins (yes or no installed could make some upsetting results due to inner coding) (all is related to php and use of mysql as mysql in that former state is deprecated and so coding is not always accepted).... If your hosting could set a lower (up to 5.3.6) the better (and start there with update).

The failed creation of those tables are the real culprit here...(forum T would become forum thread etc.... (no update sql base available so out of my head)..And that would be as mentioned php version/mysql issue.. (and the older v1 version a little). (dbase tables get new names, and postings etc..are set over)

If you are able to share your files and dbase (not public;always by PM) , i could run some tests; but you also could use local xampp install and do your changes there ( xamp;wamp can select base for php versions).

Keep us up to date with info 




 

0 like 0 dislike

So, I have checked all settings in "tools/database". It all seems fine with the right permissions set.

I did not update to php 7, I kept the 5.6.30. I dont know if I can get my ISP to roll back to an earlier version. My 1.0 version also ran on that php version, so no changes there.

I still get the two error messages when I try to update the forum (v1.2) during step 2, "create new tables":

Creating table forum_thread

Creating table forum_post

Creation of table(s) failed. You can not continue until these are created successfully!

My forum is not that big, and if I DM you are you able to scan for any fix or something I'm doing wrong?
I guess the only thing I still havent tried is to rollback to v1.0 and the old php database. (all new tabels createt in the php from the upgrade to 2.1.15, do I need to delete them or will they be overwritten?) eg, automaticly deleted?)

 

Hmm, I update this post as I remembered that I did a forum post test before I tried to update the forum to 1.2. When I did this the two posts in the php-database were created (forum_thread and forum_post). Could it be that this halts the creation of those two threads when I try to upgrade?? "Creation of table(s) failed."

If this is true, can I just delete those two posts in the php-database? Worth a try? (I'm not that experienced in php-maintenance so I need to ask first, at least then I know that I might destroy it all...)

 

//Math

 

 

answered by (22 points) 1 2 5
reshown by
IFF those 2 tables (thread and post) ONLY have your newly added content (and theres why a backup always is important (you could also create  new dbase copy of the one you now have)) then YES delete the tables..Not only the content in it (it also might be the case it will not go beyond step 2 because the tables exist.  It becomes a 'trial and error setting.. if all fails you can go to backup...

As for the PM (click when logged in on name (to who), you than can send messages (and evt. paste a download url)....  All is kept privat.. (if ALL (files and dbase) are not that large, the more complete the better... But it is up to you if you like to do so. Just trying to help. (this way is easier than supplying access as 'owner' to sites server and dbase..
0 like 0 dislike

You are very welcome, and glad you could work it out. Be wise and keep working copies of BOTH situations... one might never know... I upvoted youre own answers as the best one (as it is). yes

answered by (2.7k points) 5 8 18
Welcome to e107 Q&A, where you can ask questions and receive answers from other members of the e107 community.
747 questions
1,157 answers
1,968 comments
1,242 users