e107help.org Q&A
0 like 0 dislike

I have just upgraded my E-107 to latest 2.15 from 1.04 but when I change php to 7, it gives error:

[6]: Unable to form a valid connection to mySQL. Please check that your e107_config.php contains the correct information.an

With config file is OK. What to do? Please help

e107 version 2.15
asked in Updating by (178 points) 2 4 4

13 Answers

0 like 0 dislike

My answer dissapeared 2trd time

1. I changed your codes, it was bad: I got Lithuanian characters with hieroglyph...so I came back.

2. I am using Firefox, enabled e-107 debug but don't see when I signing what to debug

3. as for v1 or v2 - My site was created in 2008 and didn't touched since version 1,04. Now I upgraded to 2,15 (overwriting files in admin panel of server), what I have, I don't know...

4. By changing a theme I lost all my order. So I need everything to redo. (vam107.audrone.serveriai.lt)

.If you thing this is add, delete the address.

5. I preffer to do new installation in new folder, but as I wrote, I can't.

So, I am totally confused what to do

 

answered by (178 points) 2 4 4
edited by
Site looks good. What do you mean by "lost your order"?  It has nothing with theme.
0 like 0 dislike
I don't see nothing mine, some strange articles
answered by (178 points) 2 4 4
Finally I have installed a new e-107 to the new folder w.audro....

Admin of server sugested to add aditional outside host like mine IP to the datebase. I have added, but installation didn't succeded, than sugested to add 127.0.0.1

The installation quide said that such database already exit (???), to overide? I agreed to ovewrite and installation suceeded.

So I think I will work on the new website better

Do you suggest some good free template?
Finally I have installed a new e-107 to the new folder w.audro....

Admin of server suggested to add aditional outside host like mine IP to the datebase. I have added, but installation didn't succeded, than suggested to add 127.0.0.1

The installation quide said that such database already exit (???), "to overide?"  I agreeded to ovewrite and installation suceeded.

So I think I will work on the new website better. Do you suggest some good free template?
Because you imported demo theme content and these article are newer than yours one. Just delete them in news section.
Nice that it worked. Now when you would need the old items back (from the v1) an alternative method would be to use the data inside a backupped database.. Will be manual mode by INSERT, but it is do-able.

SInce you refer ip 127....... your server might be a 'special' case as described earlier..

info : the existing dbase was the fresh (by panel) created dbase, it is common to let it be overwritten (likely dbcreation during install was selected..
0 like 0 dislike

Jimako,

Yes, I understand. I need to work on it. At present I switched the old website to the old theme to easier  find my articles and really I will work in the new installiation with your "red" template step by step. http://w.audrone.serveriai.lt

The old site I will delete because really there I am confused between v1 and v2, some modules are written LAN with some number, - I can't understand what it is

THANK YOU ALL GYES FOR HELP.  I REALLY APPRECIATE IT !

answered by (178 points) 2 4 4
Hi, if you seen LAN_xxx it means that some translation in your language is missing.

I liked theme you had there before? It was from version 1? I have backup without this theme, so I am not sure.
@Jimako; just informative.. the first theme i saw in use was a slightly changed v1 core theme Khatru
Welcome to e107 Q&A, where you can ask questions and receive answers from other members of the e107 community.
797 questions
1,200 answers
2,065 comments
936 users