e107help.org Q&A
0 like 0 dislike

I am trying to run the initial installation of e107. The initial database check works, it says its connected and verified, and the checklist has all green ticks. Once its done there's a "click here" to finish the installation, but it then hits the following error:

The installer could not select database: 'bfgel-v4h-u-097306'


MySQL Reported Error:
SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '-v4h-u-097306' at line 1

I am guessing theres some conflict between my hosting DB version/type/something and e107, but thats a wild guess really. I've deleted the DB and created fresh ones a couple of times, but that doesnt work. Same error.

I am hosting with 123-reg.co.uk, a large provider. Via their control panel I can view these settings:

Database server

  • Server: mysql1.clusterdb.net via TCP/IP
  • Server type: MariaDB
  • Server version: 10.0.28-MariaDB - MariaDB Server
  • Protocol version: 10
  • User: bfgel-v4h-u-097306@10.16.11.13
  • Server charset: UTF-8 Unicode (utf8)

Web Server

  • Apache/2.2.15 (CentOS)
  • Database client version: libmysql - 5.1.73
  • PHP extension: mysqli Documentation
  • PHP version: 5.3.3

Any help would be greatly appreciated.

D

e107 version 2.1.4
asked in Installation by (2 points) 1 1

1 Answer

0 like 0 dislike

Most probably it is the php version. The installer should/would inform you version 5.4 and up for running v2 (.1.4).

Most servers do not use php 5.3.x anymore; quote from other source : PHP 5.3 back in 2009 when it first debuted. Five years later PHP 5.3 is now at its End of Life (2014), dead and abandoned as newer versions have replaced it. V2.x contains newer coding which 5.3 can not handle anymore..

(sidenote: the first alpha pack could, but in progress all was future developement > eg lowest version php 5.4;  This will end in time also.... as v2 is capable of using php 7 and test/working installs on 7.1)

Maria db should not be of influence as many use it too.

From your host : https://www.123-reg.co.uk/support/answers/Web-Hosting/Website-Help-and-Diagnostics/how-to-switch-the-php-version-4235/  (go to near bottom for 1 alternative solution).

Note php 7 is available.. not for you ?. 

answered by (2.8k points)
edited by
I don't think it's the PHP version that is causing the error here, but an upgrade is definitely required to PHP 5.4 minimal but preferably to 5.6 or higher (7 for instance). I think the error is triggered because of the database name (either too long, dashes, or something else).

Try to find Cameron on Gitter with this error message, he may have an idea: https://gitter.im/e107inc/e107
Welcome to e107 Q&A, where you can ask questions and receive answers from other members of the e107 community.
797 questions
1,202 answers
2,068 comments
939 users