e107help.org Q&A
0 like 0 dislike
Because I was asked to upgrade to E107 version 2 I needed to upgrade the PHP version on my provider. Now things are running on PHP 5.6, and V2 comes up nicely, but the old site is down:

[Tue Dec 27 10:46:29.452252 2016] [proxy_fcgi:error] [pid 4601:tid 140367873578752] [client 207.46.13.189:7911] AH01071: Got error 'PHP message: PHP Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /home/iusiixfci/domains/netwerkouderinitiatieven.nl/public_html/site/e107_handlers/mysql_class.php:144\nStack trace:\n#0 /home/iusiixfci/domains/netwerkouderinitiatieven.nl/public_html/site/class2.php(307): db->db_Connect('localhost', 'iusiixfci_nwo', 'xxxxxx', 'xxxxx')\n#1 /home/iusiixfci/domains/netwerkouderinitiatieven.nl/public_html/site/news.php(19): require_once('/home/iusiixfci...')\n#2 {main}\n thrown in /home/iusiixfci/domains/netwerkouderinitiatieven.nl/public_html/site/e107_handlers/mysql_class.php on line 144\n'

Some issue with MySQL as it appears. Is there some solution?
e107 version 1.04
closed with the note: solved
asked in Installation by (215 points) 3 7 11
closed by
Well php 5.6 and mysql > in newer php versions as php 5.6 you run into problems with mysql as is is deprecated.V2 is adapted to run (pref) with PDO( mysql too if that is the case). A lot of things (certainly plugins) that use mysql calls will suffer. Is v1 capable of running in 5.6 ? > YES Has it interfering things: yes. Which ones : hard to tell (as all sites use different things). A normal basic v1 should run quite nice.. Looking at hoster the info is low yes one can change (or ask for) but what actually is running is unknown. Since v2 runs hosting should work well.. SO back to the start : something in your v1 installation is keeping the content from running. Just look at your source of the site.. It stops right after the meta tags... what happens if you change the theme (bulletin) to jayya (as runs for admin) f.e. (you will likely know if some external scripting takes place or extra plugins run on startup).. No solution, just pointers to look at.

5 Answers

0 like 0 dislike
Tnx tgtje. I was hoping for an easy solution. The minimum requirements of V2 are PHP 5.3 but I'll see what I can do.
answered by (215 points) 3 7 11

Update : v2 >  php 5.4 min.. (pref 5.6 and up)

Alternative (just a possibilty) add  in config php.

It might help or not... 

define('e_PDO',true);

And if host allows/possible htaccess :

AddHandler application/x-httpd-php53 .php .php5 .php4 .php3

method to switch (if possible) to php 5.3 

Solved? site is running..

Mooi... opgelost ?
0 like 0 dislike
Hi Tgtje,

Yes, you where quicker than I can respond. The provider has enabled mysql as this is deprecated, but still supported in php 5.6. Then I still had issues, but I managed to solve those by updating the core table. Something inside there didn't like the new server it was running on I guess. So I'm a happy man now. Can upgrade the site to v2 while the old one is on air.
answered by (215 points) 3 7 11
Quick host, due note : future is not this setting! as it will bring troubles..

Thanks for sharing info, success with site.
0 like 0 dislike
MySQL driver is deprecated in 5.5/5.6 but not available in 7. So yes you are right. But if you need to upgrade you need an overlap in php versions as you cannot host two sites on one domain on two different php versions. It's a lesson for people who need to upgrade and need to maintain the old version. You need at least php 5.4 afaik to be able to install v2. By default v1 will not run under V5.5 or f.6 unless the mysql extension is active. Fortunately I have a good provider.
answered by (215 points) 3 7 11
0 like 0 dislike
Basically, if your old site is v1.x, and your provider has PHP 5.4 or higher, it might have some issues, since V1.x was way older than PHP 5.4, and there's a lot of code changed inside PHP.
answered by (297 points) 9 20 22
0 like 0 dislike
Latest updates of e107 v1.4 was 21-5-2013. Releasedate of php 5.4 29-2-2012. I think that a lot of people are running old versions on 5.4 and actually I never had issues except for 5.6 which was installed because I needed to move the old side into the new world of php and e107 v2. Point here is that under normal circumstances the most succesful way to upgrade your site while maintaining the old site is using php 5.4 and once your v2 site is up moveon to 5.6 or 7. That is, if you want to do all on one webhosting package and if your provider supports it. In my case I had no option than to move to another server supporting only 5.6 or 7.
answered by (215 points) 3 7 11

So at question point the issue has been solved. If so please close post.

The 'workaround' due to different server settings and the present software (php mysql etc..) will always have an influence.

As mentioned before (also github) best practice will/seems to update existing v1 sites as quickly as possible (before too heavy changes take effect) OR rework as update by using a piece of software like Xampp/Wamp or alike (at local base) and slowly shift/amend to v2 which than will work on most present servers...

Welcome to e107 Q&A, where you can ask questions and receive answers from other members of the e107 community.
797 questions
1,202 answers
2,068 comments
939 users