e107help.org Q&A
0 like 0 dislike
I just donloaded the 1.x to 2.1.2 update only to discover that there's no install.php file, hence I cannot upgrade!
e107 version 1.0.4
asked in Updating by (14 points) 1 1 1

Hihi devil  i will stick to my answer since we are talking upgrade packs > normally the place for users who want to download e107 through e107 org...( dl source = SF not git). 

Having an install file in an upgrade pack will cause havock (or at least error messages or site url will point to install, which could be desastrous).

The very latest files (up to date) of course are the ones from Github wink  (those are the ones we normally are eager to use :-) ) and voila : there are the install files...(as in all full packs too).....

 

 

tgjte is correct. The UPDATE packages never include the install.php file because it simply is not required. The FULL packages do include the install.php file, obviously.
@tgtje @Moc Ok, my fault.

But neverthless, those upgrade packages in e107.org (or even the install packages) are outdated, since github one's are always updated...

Do not mind wink you are correct on the date of files looking outdated, but again that is different than github; Github is work in progress and the available packs on SF should be regarded as 'stable' (ok point in time). (updating those each time a file has changed....time consumation). And please do not forget > they also provide the issues. ( and that in itself will ultimately will end in a new upgrade pack which is better ; looping effect.. )

3 Answers

0 like 0 dislike

Oops you have overlooked something maybe : well  wink

Your site v1 is running : log in (maintenance mode ??)

Unpack ( v2 x zip) and by FTP overwrite all files and folders with those out of the v2.x pack. (get also latest language packs if other than english : https://github.com/e107inc/e107-v2.x-Language-Packs, same procedure )

In admin (you would still be there) refresh and just look, read and work from there...

Success  (install files are for fresh websites)

answered by (2.8k points)
And debugging the white screen, what does it gives?

It sounds to me that's a php error somewhere...
how do I turn on the debug?
If you use firefox, get the e107 debug plugin, and after install it, just set it to debug all...

On other browsers, there's no debug plugin... :(
debugger produces nothing but a soild white screen.  Going to check the server logs
0 like 0 dislike

Well, it appears the error log was quite fruitful.  Lots of php errors including the below:

[Wed Nov 30 12:51:47.631913 2016] [:error] [pid 15825] [client 68.191.49.137:51258] PHP Fatal error:  Class 'DOMDocument' not found in /home/lcc/www/htdocs/e107_handlers/e_parse_class.php on line 3293, referer: http://litchfieldcountyco$
[Wed Nov 30 12:52:00.830872 2016] [:error] [pid 4369] [client 68.191.49.137:51267] PHP Fatal error:  Class 'DOMDocument' not found in /home/lcc/www/htdocs/e107_handlers/e_parse_class.php on line 3293
[Wed Nov 30 12:52:56.819914 2016] [:error] [pid 14863] [client 68.191.49.137:51295] PHP Fatal error:  Class 'DOMDocument' not found in /home/lcc/www/htdocs/e107_handlers/e_parse_class.php on line 3293
[Wed Nov 30 12:52:58.082381 2016] [:error] [pid 15840] [client 68.191.49.137:51296] PHP Fatal error:  Class 'DOMDocument' not found in /home/lcc/www/htdocs/e107_handlers/e_parse_class.php on line 3293

The error in bold red is the first one that comes up on site load

answered by (14 points) 1 1 1
OK fixed that problem and now have a new one.  When I go to update I get in System Debug:

Update required in update_routines.php on line 1317 (Avatar paths require updating.)

Couldn't Save to Log File: ../e107_system/bd69020aac/logs/2016-11-30_21-28-00_70519890_upgrade_v1_to_v2.log

Error writing file: ../e107_system/bd69020aac/cache/db/admin_log.php

Update required in update_routines.php on line 465 (Missing pref: admin_separate_plugins)
AT moment i posted, those errors might be gone ( looks a little like chmod is somewhat off) just check (if appears again) if the folder/-/paths files are present : that will give a quick answer.
As for your site LLC using v1 core theme.... looks running nicely.
The only thing i discovered (needs a dev point of view ) is this debug message :

SEF Debug Info

action=
route= news/list/items
e_QUERY=
_GET= Array ( [tag] => )

I can not tell if it is ok, or wrong.. but debugging off = error gone of course, not noticable in function
The errrors I'm talking about show up in the admin area with the debugger on and I cannot update the database:  On the database update page I get:

System Debug

Update required in update_routines.php on line 1317 (Avatar paths require updating.)

Update required in update_routines.php on line 465 (Missing pref: admin_separate_plugins)

On the admin homepage I get:

System Debug

Update required in update_routines.php on line 1317 (Avatar paths require updating.)
@mattlcc: This issue requires manual debugging. Please contact Cameron (@CaMer0n) on Gitter (the chatroom that we use) in order to solve your database update issue: https://gitter.im/e107inc/e107
0 like 0 dislike
Should I sync with Github?
answered by (14 points) 1 1 1
It is wise to so in order to include the latest changes and fixes, but they will not solve your present issue. See my comment above. You'll need manual debugging help on your website from Cameron.

@Moc just informative : #367 + 591 maybe there were some ideas too?

Yeah I recognized the issue from those reports as well as my testing from the alpha version a few years ago. Thanks Leo :)

Matt and Cameron have worked together through Gitter and his issue are resolved.
Welcome to e107 Q&A, where you can ask questions and receive answers from other members of the e107 community.
797 questions
1,200 answers
2,065 comments
936 users